uci: increase argv size in batch mode to silence a false gcc 4.4 compiler warning
[openwrt.git] / package / uci / Makefile
index 1cf6dd8..b88e72c 100644 (file)
@@ -4,12 +4,11 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
-UCI_VERSION=0.4
-UCI_RELEASE=4
+UCI_VERSION=0.7
+UCI_RELEASE=5
 
 PKG_NAME:=uci
 PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
@@ -17,7 +16,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=1ce8e92e3aa023763e8f4da91a70563d
+PKG_MD5SUM:=ed34c5ef606a90da4aba03ce6d22eeb9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -47,14 +46,20 @@ endef
 define Build/Configure
 endef
 
+TARGET_CFLAGS += $(FPIC)
 UCI_MAKEOPTS = \
                $(TARGET_CONFIGURE_OPTS) \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
                VERSION="$(UCI_VERSION)" \
-               CPPFLAGS="-I$(PKG_BUILD_DIR) -I$(STAGING_DIR)/usr/include" \
+               CPPFLAGS="-I$(PKG_BUILD_DIR) $(TARGET_CPPFLAGS)" \
                OS="Linux"
 
+# work around a nasty gcc bug
+ifneq ($(CONFIG_GCC_VERSION_4_2_4),)
+  UCI_MAKEOPTS += WOPTS=""
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(UCI_MAKEOPTS)
        $(MAKE) -C $(PKG_BUILD_DIR)/lua $(UCI_MAKEOPTS)
@@ -74,7 +79,7 @@ define Package/uci/install
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uci $(1)/sbin/
-       $(CP) ./files/uci/* $(1)/
+       $(CP) ./files/* $(1)/
 endef
 
 define Build/InstallDev
@@ -82,6 +87,8 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/uci{,_config}.h $(1)/usr/include
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libuci.a $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/libucimap.a $(1)/usr/lib
 endef
 
 $(eval $(call BuildPackage,uci))