fix broadcom-wl dependancies
[openwrt.git] / package / spca5xx / Makefile
index 0a84d98..b4025d7 100644 (file)
@@ -1,30 +1,35 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
-include $(TOPDIR)/package/kernel.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=spca5xx
 PKG_VERSION:=20060301
 PKG_RELEASE:=1
 PKG_MD5SUM:=4160e03c408ac254111febacf058b88a
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 #FIXME: add proper dependency handling on kmod-usb-core & kmod-videodev packages
 define Package/kmod-spca5xx
- SECTION:=drivers
- CATEGORY:=Drivers
- DEPENDS:=@PACKAGE_KMOD_USB&&PACKAGE_KMOD_VIDEODEV
- TITLE:=Driver for SPCA5xx based USB cameras
- DESCRIPTION:=Driver for SPCA5xx based USB cameras
- URL:=http://mxhaard.free.fr/
- VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+SECTION:=drivers
+CATEGORY:=Drivers
+DEPENDS:=@PACKAGE_KMOD_USB&&PACKAGE_KMOD_VIDEODEV
+TITLE:=Driver for SPCA5xx based USB cameras
+DESCRIPTION:=Driver for SPCA5xx based USB cameras
+URL:=http://mxhaard.free.fr/
+VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
 
 define Build/Compile