hostapd: backport fix for CVE-2015-1863, refresh patches
[openwrt.git] / package / network / services / hostapd / patches / 600-ubus_support.patch
index b17d8f2..1efe84e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -116,6 +116,11 @@ OBJS += ../src/common/wpa_common.o
+@@ -121,6 +121,11 @@ OBJS += ../src/common/hw_features_common
  
  OBJS += ../src/eapol_auth/eapol_auth_sm.o
  
  CFLAGS += -O0 -fprofile-arcs -ftest-coverage
 --- a/src/ap/hostapd.h
 +++ b/src/ap/hostapd.h
-@@ -12,6 +12,7 @@
- #include "common/defs.h"
+@@ -13,6 +13,7 @@
+ #include "utils/list.h"
  #include "ap_config.h"
  #include "drivers/driver.h"
 +#include "ubus.h"
  
  struct wpa_ctrl_dst;
  struct radius_server_data;
-@@ -99,6 +100,7 @@ struct hostapd_data {
+@@ -103,6 +104,7 @@ struct hostapd_data {
        struct hostapd_iface *iface;
        struct hostapd_config *iconf;
        struct hostapd_bss_config *conf;
 +      struct hostapd_ubus_bss ubus;
        int interface_added; /* virtual interface added for this BSS */
        unsigned int started:1;
-@@ -254,6 +256,8 @@ struct hostapd_iface {
+       unsigned int disabled:1;
+@@ -286,6 +288,8 @@ struct hostapd_iface {
        struct hostapd_config *conf;
        char phy[16]; /* Name of the PHY (radio) */
  
@@ -41,7 +41,7 @@
                HAPD_IFACE_DISABLED,
 --- /dev/null
 +++ b/src/ap/ubus.c
-@@ -0,0 +1,373 @@
+@@ -0,0 +1,511 @@
 +/*
 + * hostapd / ubus support
 + * Copyright (c) 2013, Felix Fietkau <nbd@openwrt.org>
@@ -55,6 +55,7 @@
 +#include "utils/eloop.h"
 +#include "common/ieee802_11_defs.h"
 +#include "hostapd.h"
++#include "wps_hostapd.h"
 +#include "sta_info.h"
 +#include "ubus.h"
 +
 +static struct blob_buf b;
 +static int ctx_ref;
 +
++static inline struct hostapd_data *get_hapd_from_object(struct ubus_object *obj)
++{
++      return container_of(obj, struct hostapd_data, ubus.obj);
++}
++
++
 +struct ubus_banned_client {
 +      struct avl_node avl;
 +      u8 addr[ETH_ALEN];
 +      return 0;
 +}
 +
++static int
++hostapd_bss_wps_start(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = hostapd_wps_button_pushed(hapd, NULL);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++static int
++hostapd_bss_wps_cancel(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = hostapd_wps_cancel(hapd);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++static int
++hostapd_bss_update_beacon(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      int rc;
++      struct hostapd_data *hapd = container_of(obj, struct hostapd_data, ubus.obj);
++
++      rc = ieee802_11_set_beacon(hapd);
++
++      if (rc != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      return 0;
++}
++
++enum {
++      CSA_FREQ,
++      CSA_BCN_COUNT,
++      __CSA_MAX
++};
++
++static const struct blobmsg_policy csa_policy[__CSA_MAX] = {
++      /*
++       * for now, frequency and beacon count are enough, add more
++       * parameters on demand
++       */
++      [CSA_FREQ] = { "freq", BLOBMSG_TYPE_INT32 },
++      [CSA_BCN_COUNT] = { "bcn_count", BLOBMSG_TYPE_INT32 },
++};
++
++#ifdef NEED_AP_MLME
++static int
++hostapd_switch_chan(struct ubus_context *ctx, struct ubus_object *obj,
++                  struct ubus_request_data *req, const char *method,
++                  struct blob_attr *msg)
++{
++      struct blob_attr *tb[__CSA_MAX];
++      struct hostapd_data *hapd = get_hapd_from_object(obj);
++      struct csa_settings css;
++
++      blobmsg_parse(csa_policy, __CSA_MAX, tb, blob_data(msg), blob_len(msg));
++
++      if (!tb[CSA_FREQ])
++              return UBUS_STATUS_INVALID_ARGUMENT;
++
++      memset(&css, 0, sizeof(css));
++      css.freq_params.freq = blobmsg_get_u32(tb[CSA_FREQ]);
++      if (tb[CSA_BCN_COUNT])
++              css.cs_count = blobmsg_get_u32(tb[CSA_BCN_COUNT]);
++
++      if (hostapd_switch_channel(hapd, &css) != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++      return UBUS_STATUS_OK;
++}
++#endif
++
++enum {
++      VENDOR_ELEMENTS,
++      __VENDOR_ELEMENTS_MAX
++};
++
++static const struct blobmsg_policy ve_policy[__VENDOR_ELEMENTS_MAX] = {
++      /* vendor elements are provided as hex-string */
++      [VENDOR_ELEMENTS] = { "vendor_elements", BLOBMSG_TYPE_STRING },
++};
++
++static int
++hostapd_vendor_elements(struct ubus_context *ctx, struct ubus_object *obj,
++                      struct ubus_request_data *req, const char *method,
++                      struct blob_attr *msg)
++{
++      struct blob_attr *tb[__VENDOR_ELEMENTS_MAX];
++      struct hostapd_data *hapd = get_hapd_from_object(obj);
++
++      blobmsg_parse(ve_policy, __VENDOR_ELEMENTS_MAX, tb,
++                    blob_data(msg), blob_len(msg));
++
++      if (!tb[VENDOR_ELEMENTS])
++              return UBUS_STATUS_INVALID_ARGUMENT;
++
++      const char *vendor_elements = blobmsg_data(tb[VENDOR_ELEMENTS]);
++      if (hostapd_set_iface(hapd->iconf, hapd->conf, "vendor_elements",
++                            vendor_elements) != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++
++      /* update beacons if vendor elements were set successfully */
++      if (ieee802_11_update_beacons(hapd->iface) != 0)
++              return UBUS_STATUS_NOT_SUPPORTED;
++      return UBUS_STATUS_OK;
++}
++
 +static const struct ubus_method bss_methods[] = {
 +      UBUS_METHOD_NOARG("get_clients", hostapd_bss_get_clients),
 +      UBUS_METHOD("del_client", hostapd_bss_del_client, del_policy),
 +      UBUS_METHOD_NOARG("list_bans", hostapd_bss_list_bans),
++      UBUS_METHOD_NOARG("wps_start", hostapd_bss_wps_start),
++      UBUS_METHOD_NOARG("wps_cancel", hostapd_bss_wps_cancel),
++      UBUS_METHOD_NOARG("update_beacon", hostapd_bss_update_beacon),
++#ifdef NEED_AP_MLME
++      UBUS_METHOD("switch_chan", hostapd_switch_chan, csa_policy),
++#endif
++      UBUS_METHOD("set_vendor_elements", hostapd_vendor_elements, ve_policy),
 +};
 +
 +static struct ubus_object_type bss_object_type =
 +#endif
 --- a/src/ap/hostapd.c
 +++ b/src/ap/hostapd.c
-@@ -261,6 +261,7 @@ static void hostapd_free_hapd_data(struc
+@@ -277,6 +277,7 @@ static void hostapd_free_hapd_data(struc
        hapd->started = 0;
  
        wpa_printf(MSG_DEBUG, "%s(%s)", __func__, hapd->conf->iface);
        iapp_deinit(hapd->iapp);
        hapd->iapp = NULL;
        accounting_deinit(hapd);
-@@ -864,6 +865,8 @@ static int hostapd_setup_bss(struct host
+@@ -1098,6 +1099,8 @@ static int hostapd_setup_bss(struct host
        if (hapd->driver && hapd->driver->set_operstate)
                hapd->driver->set_operstate(hapd->drv_priv, 1);
  
        return 0;
  }
  
-@@ -1154,6 +1157,7 @@ int hostapd_setup_interface_complete(str
+@@ -1384,6 +1387,7 @@ int hostapd_setup_interface_complete(str
        if (err)
                goto fail;
  
        wpa_printf(MSG_DEBUG, "Completing interface initialization");
        if (iface->conf->channel) {
  #ifdef NEED_AP_MLME
-@@ -1265,6 +1269,7 @@ int hostapd_setup_interface_complete(str
+@@ -1544,6 +1548,7 @@ dfs_offload:
  
  fail:
        wpa_printf(MSG_ERROR, "Interface initialization failed");
        hostapd_set_state(iface, HAPD_IFACE_DISABLED);
        wpa_msg(hapd->msg_ctx, MSG_INFO, AP_EVENT_DISABLED);
        if (iface->interfaces && iface->interfaces->terminate_on_error)
-@@ -1587,6 +1592,7 @@ void hostapd_interface_deinit_free(struc
+@@ -1873,6 +1878,7 @@ void hostapd_interface_deinit_free(struc
                   (unsigned int) iface->conf->num_bss);
        driver = iface->bss[0]->driver;
        drv_priv = iface->bss[0]->drv_priv;
                   __func__, driver, drv_priv);
 --- a/src/ap/ieee802_11.c
 +++ b/src/ap/ieee802_11.c
-@@ -542,7 +542,8 @@ failed:
+@@ -881,7 +881,8 @@ int auth_sae_init_committed(struct hosta
  
  
  static void handle_auth(struct hostapd_data *hapd,
  {
        u16 auth_alg, auth_transaction, status_code;
        u16 resp = WLAN_STATUS_SUCCESS;
-@@ -557,6 +558,11 @@ static void handle_auth(struct hostapd_d
-       size_t resp_ies_len = 0;
+@@ -897,6 +898,11 @@ static void handle_auth(struct hostapd_d
        char *identity = NULL;
        char *radius_cui = NULL;
+       u16 seq_ctrl;
 +      struct hostapd_ubus_request req = {
 +              .type = HOSTAPD_UBUS_AUTH_REQ,
 +              .mgmt_frame = mgmt,
  
        if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.auth)) {
                wpa_printf(MSG_INFO, "handle_auth - too short payload (len=%lu)",
-@@ -640,6 +646,14 @@ static void handle_auth(struct hostapd_d
+@@ -983,6 +989,14 @@ static void handle_auth(struct hostapd_d
                resp = WLAN_STATUS_UNSPECIFIED_FAILURE;
                goto fail;
        }
        if (res == HOSTAPD_ACL_PENDING) {
                wpa_printf(MSG_DEBUG, "Authentication frame from " MACSTR
                           " waiting for an external authentication",
-@@ -1274,13 +1288,18 @@ static void send_assoc_resp(struct hosta
+@@ -1694,13 +1708,18 @@ static void send_assoc_resp(struct hosta
  
  static void handle_assoc(struct hostapd_data *hapd,
                         const struct ieee80211_mgmt *mgmt, size_t len,
 -                       int reassoc)
 +                       int reassoc, struct hostapd_frame_info *fi)
  {
-       u16 capab_info, listen_interval;
+       u16 capab_info, listen_interval, seq_ctrl, fc;
        u16 resp = WLAN_STATUS_SUCCESS;
        const u8 *pos;
        int left, i;
  
        if (len < IEEE80211_HDRLEN + (reassoc ? sizeof(mgmt->u.reassoc_req) :
                                      sizeof(mgmt->u.assoc_req))) {
-@@ -1379,6 +1398,13 @@ static void handle_assoc(struct hostapd_
+@@ -1820,6 +1839,13 @@ static void handle_assoc(struct hostapd_
                goto fail;
        }
  
        sta->capability = capab_info;
        sta->listen_interval = listen_interval;
  
-@@ -1760,7 +1786,7 @@ int ieee802_11_mgmt(struct hostapd_data 
+@@ -2236,7 +2262,7 @@ int ieee802_11_mgmt(struct hostapd_data
  
  
        if (stype == WLAN_FC_STYPE_PROBE_REQ) {
                return 1;
        }
  
-@@ -1775,17 +1801,17 @@ int ieee802_11_mgmt(struct hostapd_data 
+@@ -2251,17 +2277,17 @@ int ieee802_11_mgmt(struct hostapd_data
        switch (stype) {
        case WLAN_FC_STYPE_AUTH:
                wpa_printf(MSG_DEBUG, "mgmt::auth");
        case WLAN_FC_STYPE_DISASSOC:
 --- a/src/ap/beacon.c
 +++ b/src/ap/beacon.c
-@@ -498,7 +498,7 @@ static enum ssid_match_result ssid_match
+@@ -542,7 +542,7 @@ static enum ssid_match_result ssid_match
  
  void handle_probe_req(struct hostapd_data *hapd,
                      const struct ieee80211_mgmt *mgmt, size_t len,
  {
        u8 *resp;
        struct ieee802_11_elems elems;
-@@ -506,8 +506,14 @@ void handle_probe_req(struct hostapd_dat
+@@ -550,8 +550,14 @@ void handle_probe_req(struct hostapd_dat
        size_t ie_len;
        struct sta_info *sta = NULL;
        size_t i, resp_len;
  
        ie = mgmt->u.probe_req.variable;
        if (len < IEEE80211_HDRLEN + sizeof(mgmt->u.probe_req))
-@@ -645,6 +651,12 @@ void handle_probe_req(struct hostapd_dat
+@@ -710,6 +716,12 @@ void handle_probe_req(struct hostapd_dat
        }
  #endif /* CONFIG_P2P */