hostapd: correctly handle macfile uci option
[openwrt.git] / package / network / services / hostapd / patches / 460-disable_ctrl_iface_mib.patch
index 2f03179..a51ade8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/Makefile
 +++ b/hostapd/Makefile
-@@ -135,6 +135,9 @@ endif
+@@ -136,6 +136,9 @@ endif
  ifdef CONFIG_NO_CTRL_IFACE
  CFLAGS += -DCONFIG_NO_CTRL_IFACE
  else
@@ -12,7 +12,7 @@
  endif
 --- a/hostapd/ctrl_iface.c
 +++ b/hostapd/ctrl_iface.c
-@@ -899,6 +899,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -937,6 +937,7 @@ static void hostapd_ctrl_iface_receive(i
        } else if (os_strncmp(buf, "RELOG", 5) == 0) {
                if (wpa_debug_reopen_file() < 0)
                        reply_len = -1;
@@ -20,7 +20,7 @@
        } else if (os_strcmp(buf, "MIB") == 0) {
                reply_len = ieee802_11_get_mib(hapd, reply, reply_size);
                if (reply_len >= 0) {
-@@ -928,10 +929,12 @@ static void hostapd_ctrl_iface_receive(i
+@@ -966,10 +967,12 @@ static void hostapd_ctrl_iface_receive(i
                                reply_len += res;
                }
  #endif /* CONFIG_NO_RADIUS */
@@ -33,7 +33,7 @@
        } else if (os_strcmp(buf, "STA-FIRST") == 0) {
                reply_len = hostapd_ctrl_iface_sta_first(hapd, reply,
                                                         reply_size);
-@@ -941,6 +944,7 @@ static void hostapd_ctrl_iface_receive(i
+@@ -979,6 +982,7 @@ static void hostapd_ctrl_iface_receive(i
        } else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
                reply_len = hostapd_ctrl_iface_sta_next(hapd, buf + 9, reply,
                                                        reply_size);
@@ -43,8 +43,8 @@
                        reply_len = -1;
 --- a/wpa_supplicant/Makefile
 +++ b/wpa_supplicant/Makefile
-@@ -751,6 +751,9 @@ ifdef CONFIG_IEEE80211N
- OBJS += ../src/ap/ieee802_11_ht.o
+@@ -758,6 +758,9 @@ ifdef CONFIG_WNM
+ OBJS += ../src/ap/wnm_ap.o
  endif
  ifdef CONFIG_CTRL_IFACE
 +ifdef CONFIG_CTRL_IFACE_MIB
@@ -55,7 +55,7 @@
  
 --- a/wpa_supplicant/ctrl_iface.c
 +++ b/wpa_supplicant/ctrl_iface.c
-@@ -4382,6 +4382,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5051,6 +5051,7 @@ char * wpa_supplicant_ctrl_iface_process
                        reply_len = -1;
        } else if (os_strncmp(buf, "NOTE ", 5) == 0) {
                wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@@ -63,7 +63,7 @@
        } else if (os_strcmp(buf, "MIB") == 0) {
                reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
                if (reply_len >= 0) {
-@@ -4393,6 +4394,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5062,6 +5063,7 @@ char * wpa_supplicant_ctrl_iface_process
                        else
                                reply_len += res;
                }
@@ -71,7 +71,7 @@
        } else if (os_strncmp(buf, "STATUS", 6) == 0) {
                reply_len = wpa_supplicant_ctrl_iface_status(
                        wpa_s, buf + 6, reply, reply_size);
-@@ -4792,6 +4794,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5465,6 +5467,7 @@ char * wpa_supplicant_ctrl_iface_process
                reply_len = wpa_supplicant_ctrl_iface_bss(
                        wpa_s, buf + 4, reply, reply_size);
  #ifdef CONFIG_AP
@@ -79,7 +79,7 @@
        } else if (os_strcmp(buf, "STA-FIRST") == 0) {
                reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
        } else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -4800,6 +4803,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -5473,6 +5476,7 @@ char * wpa_supplicant_ctrl_iface_process
        } else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
                reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
                                                   reply_size);
@@ -95,9 +95,9 @@
  
 +#ifdef CONFIG_CTRL_IFACE_MIB
  
- static int hostapd_ctrl_iface_sta_mib(struct hostapd_data *hapd,
-                                     struct sta_info *sta,
-@@ -103,6 +104,7 @@ int hostapd_ctrl_iface_sta_next(struct h
+ static int hostapd_get_sta_conn_time(struct sta_info *sta,
+                                    char *buf, size_t buflen)
+@@ -129,6 +130,7 @@ int hostapd_ctrl_iface_sta_next(struct h
        return hostapd_ctrl_iface_sta_mib(hapd, sta->next, buf, buflen);
  }
  
  
  #ifdef CONFIG_P2P_MANAGER
  static int p2p_manager_disconnect(struct hostapd_data *hapd, u16 stype,
-@@ -269,3 +271,4 @@ int hostapd_ctrl_iface_disassociate(stru
+@@ -303,3 +305,4 @@ int hostapd_ctrl_iface_disassociate(stru
  
        return 0;
  }
 +
 --- a/src/ap/ieee802_1x.c
 +++ b/src/ap/ieee802_1x.c
-@@ -2034,6 +2034,7 @@ static const char * bool_txt(Boolean boo
+@@ -2048,6 +2048,7 @@ static const char * bool_txt(Boolean boo
        return bool ? "TRUE" : "FALSE";
  }
  
  
  int ieee802_1x_get_mib(struct hostapd_data *hapd, char *buf, size_t buflen)
  {
-@@ -2186,6 +2187,7 @@ int ieee802_1x_get_mib_sta(struct hostap
+@@ -2200,6 +2201,7 @@ int ieee802_1x_get_mib_sta(struct hostap
        return len;
  }
  
                                struct sta_info *sta, int success)
 --- a/src/ap/wpa_auth.c
 +++ b/src/ap/wpa_auth.c
-@@ -2729,6 +2729,7 @@ static const char * wpa_bool_txt(int boo
+@@ -2687,6 +2687,7 @@ static const char * wpa_bool_txt(int boo
        return bool ? "TRUE" : "FALSE";
  }
  
  
  #define RSN_SUITE "%02x-%02x-%02x-%d"
  #define RSN_SUITE_ARG(s) \
-@@ -2873,7 +2874,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
+@@ -2831,7 +2832,7 @@ int wpa_get_mib_sta(struct wpa_state_mac
  
        return len;
  }
  {
 --- a/src/rsn_supp/wpa.c
 +++ b/src/rsn_supp/wpa.c
-@@ -1844,6 +1844,8 @@ static u32 wpa_key_mgmt_suite(struct wpa
+@@ -1848,6 +1848,8 @@ static u32 wpa_key_mgmt_suite(struct wpa
  }
  
  
  #define RSN_SUITE "%02x-%02x-%02x-%d"
  #define RSN_SUITE_ARG(s) \
  ((s) >> 24) & 0xff, ((s) >> 16) & 0xff, ((s) >> 8) & 0xff, (s) & 0xff
-@@ -1927,6 +1929,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
+@@ -1931,6 +1933,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
  
        return (int) len;
  }