remove duplicate package/ prefix from package dump error message
[openwrt.git] / package / mtd / Makefile
index 381184b..01b9adf 100644 (file)
@@ -1,28 +1,37 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME := mtd
-PKG_RELEASE := 4
+PKG_NAME:=mtd
+PKG_RELEASE:=4
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(TOPDIR)/package/rules.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/mtd
 SECTION:=base
-CATEGORY:=Util
+CATEGORY:=Utilities
 DEFAULT:=y
 TITLE:=Update utility for trx firmware images
 DESCRIPTION:=Update utility for trx firmware images. To update \\\
 from other firmware or older OpenWrt releases.
 endef
 
-define Build/Compile
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
 define Package/mtd/install
-       install -d -m0755 $(IDIR_MTD)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
+       install -d -m0755 $(1)/sbin
+       install -m0755 $(PKG_BUILD_DIR)/mtd $(1)/sbin/
 endef
+
+$(eval $(call BuildPackage,mtd))