more cleanup (make sure to pass TARGET_PATH and not just TARGET_CC)
[openwrt.git] / package / mtd / Makefile
index b2090a6..01b9adf 100644 (file)
@@ -1,30 +1,37 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME := mtd
-PKG_RELEASE := 1
+PKG_NAME:=mtd
+PKG_RELEASE:=4
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-ifeq ($(LINUX_VERSION),2.4.30)
-VER=-DLINUX_24
-endif
+include $(INCLUDE_DIR)/package.mk
 
-include $(TOPDIR)/package/rules.mk
+define Package/mtd
+SECTION:=base
+CATEGORY:=Utilities
+DEFAULT:=y
+TITLE:=Update utility for trx firmware images
+DESCRIPTION:=Update utility for trx firmware images. To update \\\
+from other firmware or older OpenWrt releases.
+endef
 
-$(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
+define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+       $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
 
-$(PKG_BUILD_DIR)/.prepared:
-       mkdir -p $@
-       touch $@
+define Package/mtd/install
+       install -d -m0755 $(1)/sbin
+       install -m0755 $(PKG_BUILD_DIR)/mtd $(1)/sbin/
+endef
 
-$(PKG_BUILD_DIR)/.built:
-       $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
-       touch $@
-
-$(IPKG_MTD): 
-       install -d -m0755 $(IDIR_MTD)/sbin
-       install -m0755 $(PKG_BUILD_DIR)/mtd $(IDIR_MTD)/sbin
-       $(RSTRIP) $(IDIR_MTD)/sbin/*
-       $(IPKG_BUILD) $(IDIR_MTD) $(PACKAGE_DIR)
+$(eval $(call BuildPackage,mtd))