more cleanup (make sure to pass TARGET_PATH and not just TARGET_CC)
[openwrt.git] / package / mtd / Makefile
index 01dfcd6..01b9adf 100644 (file)
@@ -1,3 +1,9 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
 # $Id$
 
 include $(TOPDIR)/rules.mk
@@ -7,11 +13,11 @@ PKG_RELEASE:=4
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
-include $(TOPDIR)/include/package.mk
+include $(INCLUDE_DIR)/package.mk
 
 define Package/mtd
 SECTION:=base
-CATEGORY:=Util
+CATEGORY:=Utilities
 DEFAULT:=y
 TITLE:=Update utility for trx firmware images
 DESCRIPTION:=Update utility for trx firmware images. To update \\\
@@ -23,12 +29,6 @@ define Build/Prepare
        $(CP) ./src/* $(PKG_BUILD_DIR)/
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
-               all
-endef
-
 define Package/mtd/install
        install -d -m0755 $(1)/sbin
        install -m0755 $(PKG_BUILD_DIR)/mtd $(1)/sbin/