madwifi: if a txpower value below the poweroffset is requested, set the internal...
[openwrt.git] / package / madwifi / Makefile
index f143f94..df4c174 100644 (file)
@@ -46,6 +46,8 @@ PKG_BUILD_DEPENDS:=wprobe
 
 include $(INCLUDE_DIR)/package.mk
 
+COMPRESSION:=1
+
 define Download/hal
   FILE:=$(HAL_FILE)
   URL:=http://mirror2.openwrt.org/sources
@@ -151,7 +153,7 @@ ifeq ($(findstring PCI,$(BUS)),PCI)
   MADWIFI_AUTOLOAD+= ath_pci
 endif
 
-MADWIFI_APPLETS:=80211stats athchans athctrl athkey athstats wlanconfig ath_info
+MADWIFI_APPLETS:=80211stats athchans athkey athstats wlanconfig ath_info
 ifdef CONFIG_MADWIFI_DEBUG
   MADWIFI_APPLETS += athdebug 80211debug
 endif
@@ -189,6 +191,7 @@ MADWIFI_INC = \
 MAKE_ARGS:= \
        PATH="$(TARGET_PATH)" \
        ARCH="$(LINUX_KARCH)" \
+       ARCH-y="$(LINUX_KARCH)" \
        CROSS_COMPILE="$(TARGET_CROSS)" \
        TARGET="$(HAL_TARGET)" \
        TOOLPREFIX="$(KERNEL_CROSS)" \
@@ -196,6 +199,7 @@ MAKE_ARGS:= \
        KERNELPATH="$(LINUX_DIR)" \
        LDOPTS="--no-warn-mismatch " \
        ATH_RATE="ath_rate/$(RATE_CONTROL)" \
+       ATH_CAP_SUPERG_COMP="$(COMPRESSION)" \
        DO_MULTI=1 \
        INCS="$(MADWIFI_INC)" \
        $(if $(CONFIG_MADWIFI_DEBUG),,DEBUG=) WARNINGS="-Wno-unused"