[package] create kmod-fb and update xen framebuffer module
[openwrt.git] / package / kernel / modules / video.mk
index d1e2be3..fecedb0 100644 (file)
@@ -8,6 +8,28 @@
 
 VIDEO_MENU:=Video Support
 
+
+define KernelPackage/fb
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Framebuffer support
+  KCONFIG:=CONFIG_FB \
+          CONFIG_FB_CFB_FILLRECT \
+          CONFIG_FB_CFB_COPYAREA \
+          CONFIG_FB_CFB_IMAGEBLIT
+  FILES:=$(LINUX_DIR)/drivers/video/fb.ko \
+        $(LINUX_DIR)/drivers/video/cfbfillrect.ko \
+        $(LINUX_DIR)/drivers/video/cfbcopyarea.ko \
+        $(LINUX_DIR)/drivers/video/cfbimgblt.ko
+  AUTOLOAD:=$(call AutoLoad,06,fb cfbfillrect cfbcopyarea cfbimgblt)
+endef
+
+define KernelPackage/fb/description
+  Kernel support for framebuffers
+endef
+
+$(eval $(call KernelPackage,fb))
+
+
 define KernelPackage/video-core
   SUBMENU:=$(VIDEO_MENU)
   TITLE=Video4Linux support
@@ -135,7 +157,7 @@ $(eval $(call KernelPackage,video-uvc))
 define KernelPackage/video-gspca-core
   MENU:=1
   TITLE:=GSPCA webcam core support framework
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-input-core
   KCONFIG:=CONFIG_USB_GSPCA
   FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_main.ko
   AUTOLOAD:=$(call AutoLoad,70,gspca_main)