kernel: load after its dependencies
[openwrt.git] / package / kernel / modules / sound.mk
index 1f2cc4e..46bc685 100644 (file)
@@ -133,12 +133,15 @@ endef
 
 $(eval $(call KernelPackage,sound-cs5535audio))
 
+
 define KernelPackage/sound-soc-core
 $(call KernelPackage/sound/Depends)
   TITLE:=SoC sound support
-  KCONFIG:=CONFIG_SND_SOC
+  KCONFIG:= \
+       CONFIG_SND_SOC \
+       CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
-  AUTOLOAD:=$(call AutoLoad,35, snd-soc-core)
+  AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)
 endef
 
 $(eval $(call KernelPackage,sound-soc-core))