block.mk: Added ata-ixp4xx-cf module support for tw5334 board.
[openwrt.git] / package / kernel / modules / block.mk
index 9a4d6ff..32aab5b 100644 (file)
@@ -11,7 +11,7 @@ BLOCK_MENU:=Block Devices
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT @LINUX_2_6
+  DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,21,libata)
@@ -23,7 +23,7 @@ $(eval $(call KernelPackage,ata-core))
 define KernelPackage/ata-artop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ARTOP 6210/6260 PATA support
-  DEPENDS:=kmod-ata-core +kmod-scsi-core
+  DEPENDS:=kmod-ata-core
   KCONFIG:=CONFIG_PATA_ARTOP
   FILES:=$(LINUX_DIR)/drivers/ata/pata_artop.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,41,pata_artop)
@@ -36,17 +36,33 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
+define KernelPackage/ata-ixp4xx-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=IXP4XX Compact Flash support
+  DEPENDS:=kmod-ata-core
+  KCONFIG:=CONFIG_PATA_IXP4XX_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_ixp4xx_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,41,pata_ixp4xx_cf)
+endef
+
+define KernelPackage/ata-ixp4xx-cf/description
+ IXP4XX Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-ixp4xx-cf))
+
+
 define KernelPackage/ata-piix
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Intel PIIX PATA/SATA support
-  DEPENDS:=kmod-ata-core +kmod-ide-core +kmod-scsi-core
+  DEPENDS:=kmod-ata-core +kmod-ide-core
   KCONFIG:=CONFIG_ATA_PIIX
   FILES:=$(LINUX_DIR)/drivers/ata/ata_piix.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,41,ata_piix)
 endef
 
 define KernelPackage/ata-piix/description
- SATA support for Intel ICH5/6/7/8 series host controllers and 
+ SATA support for Intel ICH5/6/7/8 series host controllers and
  PATA support for Intel ESB/ICH/PIIX3/PIIX4 series host controllers.
 endef
 
@@ -95,7 +111,7 @@ define KernelPackage/ide-aec62xx
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Acard AEC62xx IDE driver
   DEPENDS:=@PCI_SUPPORT +kmod-ide-core
-  KCONFIG:=CONFIG_BLK_DEV_AEC62XX 
+  KCONFIG:=CONFIG_BLK_DEV_AEC62XX
   FILES:=$(LINUX_DIR)/drivers/ide/pci/aec62xx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,30,aec62xx)
 endef
@@ -117,7 +133,7 @@ define KernelPackage/ide-pdc202xx
 endef
 
 define KernelPackage/ide-pdc202xx/description
- Support for the Promise Ultra 33/66/100 (PDC202{46|62|65|67|68}) IDE 
+ Support for the Promise Ultra 33/66/100 (PDC202{46|62|65|67|68}) IDE
  controllers.
 endef
 
@@ -184,16 +200,17 @@ endef
 $(eval $(call KernelPackage,nbd))
 
 
-define KernelPackage/rb153-cf
+define KernelPackage/pata-rb153-cf
   SUBMENU:=$(BLOCK_MENU)
-  TITLE:=RouterBoard 153 CF Slot
-  KCONFIG:=CONFIG_BLK_DEV_CF_MIPS
-  FILES:=$(LINUX_DIR)/drivers/block/rb1xx/rb153-cf.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,30,rb153-cf)
+  DEPENDS:=kmod-ata-core @TARGET_adm5120_router_le
+  TITLE:=RouterBOARD 153 CF Slot support
+  KCONFIG:=CONFIG_PATA_RB153_CF
+  FILES:=$(LINUX_DIR)/drivers/ata/pata_rb153_cf.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,pata_rb153_cf)
 endef
 
-define KernelPackage/rb153-cf/description
-  Kernel module for the RouterBoard 153 CF slot
+define KernelPackage/pata-rb153-cf/description
+  Kernel support for the RouterBoard 153 CF slot.
 endef
 
-$(eval $(call KernelPackage,rb153-cf))
+$(eval $(call KernelPackage,pata-rb153-cf))