kernel: split kmod-sched into kmod-sched-core and kmod-sched
[openwrt.git] / package / kernel / modules / 001-depends.mk
index 61d8921..aad2939 100644 (file)
@@ -1,44 +1,39 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
-# XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
-
-define SetDepends/crc16
-  DEPENDS:= @!TARGET_xburst
-endef
-
 define AddDepends/crc16
-  DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
-endef
-
-
-define SetDepends/hid
-  DEPENDS:= @!TARGET_x86
+  DEPENDS+= +kmod-lib-crc16 $(1)
 endef
 
 define AddDepends/hid
-  DEPENDS+= +!TARGET_x86:kmod-hid $(1)
-
+  DEPENDS+= +kmod-hid $(1)
 endef
 
-
-define SetDepends/input
-  DEPENDS:= @!TARGET_x86
+define AddDepends/input
+  DEPENDS+= +kmod-input-core $(1)
 endef
 
-define AddDepends/input
-  DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
+
+define AddDepends/nls
+  DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
 
 
 define SetDepends/rfkill
-  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86)
+  DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
 endef
 
 define AddDepends/rfkill
   DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
 endef
+
+
+define AddDepends/rtc
+  DEPENDS+= \
+    +(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-2.6 \
+    +!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-3.x
+endef