madwifi: add iwpriv for setting the maximum number of associated clients (ap mode)
[openwrt.git] / package / dnsmasq / Makefile
index 7dd55af..4d3beba 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.40
+PKG_VERSION:=2.45
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=91b6063ae81146b9d70b4381b2f3e44f
+PKG_MD5SUM:=b7956e15c9766e05b3eca3ce88fdb616
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,10 +25,6 @@ define Package/dnsmasq
   URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
-define Package/dnsmasq/conffiles
-/etc/dnsmasq.conf
-endef
-
 define Package/dnsmasq/description
  It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
@@ -38,6 +34,7 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               AWK="awk" \
                all
 endef