[package] base-files: implement "reqopts" parameter for dhcp interfaces to specify...
[openwrt.git] / package / base-files / Makefile
index 1f510df..01058ba 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=57
+PKG_RELEASE:=64
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
@@ -50,9 +50,14 @@ define Package/base-files/conffiles
 /etc/inittab
 /etc/group
 /etc/passwd
+/etc/shadow
 /etc/profile
 /etc/shells
 /etc/sysctl.conf
+/etc/rc.local
+/etc/sysupgrade.conf
+/etc/config/
+/etc/dropbear/
 $(call $(TARGET)/conffiles)
 endef
 
@@ -159,6 +164,7 @@ ifneq ($(TARGET_avr32)$(TARGET_coldfire),)
   DEPENDS:=+libgcc
 endif
   URL:=$(LIBC_URL)
+  PKG_FLAGS:=hold essential
 endef