firewall3: update to git head
[openwrt.git] / package / admswconfig / Makefile
index 52aa2a4..e16258f 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -24,6 +23,7 @@ define Package/admswconfig
   TITLE:=ADM5120 Switch configuration tool
   DEPENDS:=@TARGET_adm5120
   URL:=http://sharon.esrac.ele.tue.nl/users/pe1rxq/linux-adm/admswconfig/
+  MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 endef
 
 define Package/admswconfig/description
@@ -43,6 +43,10 @@ endef
 define Package/admswconfig/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/admswconfig $(1)/sbin/
+       $(INSTALL_DIR) $(1)/lib/network/
+       $(INSTALL_DATA) ./files/admswswitch.sh $(1)/lib/network/admswswitch.sh
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/admswconfig $(1)/etc/init.d/admswconfig
 endef
 
 $(eval $(call BuildPackage,admswconfig))