madwifi: preserve WPA IEs received in probe responses and prefer them over beacon...
[openwrt.git] / package / Makefile
index d213200..a1f20b0 100644 (file)
@@ -1,60 +1,58 @@
-# Main makefile for the packages
-include $(TOPDIR)/rules.mk
-COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
-INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))
-
-all: compile
-clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
-compile: $(COMPILE_PACKAGES)
-install: base-files-install $(INSTALL_PACKAGES)
-
-$(COMPILE_PACKAGES): base-files-compile
-$(INSTALL_PACKAGES): base-files-install
-
-$(STAMP_DIR):
-       mkdir -p $@
-
-$(TARGET_DIR):
-       mkdir -p $(TARGET_DIR)
-
-%-prepare: $(STAMP_DIR) $(TARGET_DIR)
-       @[ -f $(STAMP_DIR)/.$@ ] || { \
-               $(START_TRACE) "package/$(patsubst %-prepare,%,$@)-prepare: "; \
-               $(MAKE) -C $(patsubst %-prepare,%,$@) prepare && { \
-                       touch $(STAMP_DIR)/.$@; \
-                       $(CMD_TRACE) " done"; \
-                       $(END_TRACE); \
-               } \
-       }
-
-%-compile:
-       @[ -f $(STAMP_DIR)/.$@ ] || { \
-               $(START_TRACE) "package/$(patsubst %-compile,%,$@)-compile: "; \
-               $(MAKE) -C $(patsubst %-compile,%,$@) compile && { \
-                       touch $(STAMP_DIR)/.$(patsubst %-compile,%,$@)-prepare; \
-                       touch $(STAMP_DIR)/.$@; \
-                       $(CMD_TRACE) " done"; \
-                       $(END_TRACE); \
-               } \
-       }
-
-%-install: %-compile
-       @$(START_TRACE) "package/$(patsubst %-install,%,$@)-install: "
-       @$(MAKE) -C $(patsubst %-install,%,$@) install
-       @$(CMD_TRACE) " done"
-       @$(END_TRACE)
-
-%-rebuild: 
-       @$(START_TRACE) "package/$(patsubst %-rebuild,%,$@)-rebuild: "
-       @rm -f $(STAMP_DIR)/.$(patsubst %-rebuild,%,$@)-*
-       $(MAKE) -C $(patsubst %-rebuild,%,$@) rebuild
-       @$(CMD_TRACE) " done"
-       @$(END_TRACE)
-
-%-clean:
-       @$(START_TRACE) "package/$(patsubst %-clean,%,$@)-clean: "
-       @$(MAKE) -C $(patsubst %-clean,%,$@) clean
-       @rm -f $(STAMP_DIR)/.$(patsubst %-clean,%,$@)-*
-       @$(CMD_TRACE) " done"
-       @$(END_TRACE)
-
+# 
+# Copyright (C) 2006-2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+curdir:=package
+
+-include $(TMP_DIR)/.packagedeps
+$(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
+ifeq ($(SDK),1)
+  $(curdir)/builddirs-install:=.
+else
+  $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
+  $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
+  $(curdir)/builddirs-install:=. $(sort $(package-y))
+endif
+ifneq ($(IGNORE_ERRORS),)
+  $(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
+endif
+
+$(curdir)/install:=$(curdir)/install-cleanup
+
+$(curdir)/cleanup: $(TMP_DIR)/.build
+       rm -rf $(TARGET_DIR)
+
+$(curdir)/rootfs-prepare: $(TMP_DIR)/.build
+       @-$(MAKE) package/preconfig
+       @if [ -d $(TOPDIR)/files ]; then \
+               $(CP) $(TOPDIR)/files/. $(TARGET_DIR); \
+       fi
+       @mkdir -p $(TARGET_DIR)/etc/rc.d
+       @( \
+               cd $(TARGET_DIR); \
+               for script in ./etc/init.d/*; do \
+                       grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
+                       IPKG_INSTROOT=$(TARGET_DIR) $(which bash) ./etc/rc.common $$script enable; \
+               done || true \
+       )
+       @-find $(TARGET_DIR) -name CVS   | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name .svn  | $(XARGS) rm -rf
+       @-find $(TARGET_DIR) -name '.#*' | $(XARGS) rm -f
+       $(if $(CONFIG_CLEAN_IPKG),rm -rf $(TARGET_DIR)/usr/lib/ipkg)
+
+$(curdir)/index: FORCE
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+
+$(curdir)/flags-install:= -j1
+
+$(eval $(call stampfile,$(curdir),package,prereq,.config))
+$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
+
+$(eval $(call subdir,$(curdir)))