update madwifi to r1543
[openwrt.git] / openwrt / target / linux / package / madwifi / Makefile
index c192726..9f95ed1 100644 (file)
@@ -4,9 +4,9 @@ include $(TOPDIR)/rules.mk
 include ../../rules.mk
 
 PKG_NAME:=madwifi-ng
-PKG_VERSION:=r1451-20060212
+PKG_VERSION:=r1543-20060506
 PKG_RELEASE:=1
-PKG_MD5SUM:=e3bef6881d711033689964bf0b982f14
+PKG_MD5SUM:=3d89e5197c7e43eb37564c176140b2bf
 
 PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_NAME)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -23,15 +23,18 @@ endif
 ifeq ($(ARCH),i386)
 HAL_TARGET:=i386-elf
 endif
+ifeq ($(ARCH),armeb)
+HAL_TARGET:=xscale-be-elf
+endif
 
 BUS := PCI
 
 ifneq ($(BR2_LINUX_2_4_AR531X),)
        BUS := AHB
 endif
-ifneq ($(BR2_LINUX_2_6_ARUBA),)
-#      BUS := PCI AHB  # no suitable HAL for AHB yet.
-endif
+ifneq ($(BR2_LINUX_2_6_ARUBA),)
+       BUS := PCI AHB  # no suitable HAL for AHB yet.
+endif
 
 BUS_MODULES:=
 ifeq ($(findstring AHB,$(BUS)),AHB)