yate: mark mysql backed module as @BROKEN
[feed/telephony.git] / net / yate / Makefile
index 059b432..2fb8849 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 # Copyright (C) 2006-2011 SMBPhone
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -9,7 +9,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/uclibc++.mk
 
-RELEASEVER:=5.0.0
+RELEASEVER:=5.4.0
 
 PKG_NAME:=yate
 PKG_VERSION:=$(RELEASEVER)-1
@@ -17,7 +17,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://yate.null.ro/tarballs/yate5/
-PKG_MD5SUM:=6113bce2b81b402431c61d1f777e09a6
+PKG_MD5SUM:=427fd2ffde51116271534f398bf913e8
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 PKG_INSTALL:=1
@@ -44,28 +44,16 @@ define Package/$(PKG_NAME)/conffiles
 endef
 
 define Package/$(PKG_NAME)/Default/description
-  Is a next-generation telephony engine focused on the VoIP and PSTN.  It does
+  Is a next-generation telephony engine focused on the VoIP and PSTN. It does
   SIP, H.323, IAX, PSTN, and more.
 endef
 
-define Package/$(PKG_NAME)-scripts-php
-  $(call Package/yate/Default)
-  DEPENDS += $(PKG_NAME) $(PKG_NAME)-mod-extmodule +php5 +php5-cli
-  TITLE:= PHP Scripts and script libraries for Yate
-endef
-
 define Package/$(PKG_NAME)-scripts-perl
   $(call Package/yate/Default)
-  DEPENDS += $(PKG_NAME) $(PKG_NAME)-mod-extmodule +microperl
+  DEPENDS += $(PKG_NAME) $(PKG_NAME)-mod-extmodule +perl
   TITLE:= Perl module for Yate
 endef
 
-define Package/$(PKG_NAME)-scripts-python
-  $(call Package/yate/Default)
-  DEPENDS += $(PKG_NAME) $(PKG_NAME)-mod-extmodule +python-mini
-  TITLE:= Python module for Yate
-endef
-
 define Package/$(PKG_NAME)-sounds
   $(call Package/yate/Default)
   DEPENDS += $(PKG_NAME)
@@ -94,14 +82,14 @@ CONFIGURE_ARGS+= \
        --enable-inline \
        --enable-atomics \
        --disable-sse2 \
-       --enable-sctp \
+       --disable-sctp \
        --enable-resolver \
        --enable-internalregex \
        --disable-dahdi \
        --disable-zaptel \
        --disable-wpcard \
        --disable-tdmcard \
-       --enable-wanpipe \
+       --disable-wanpipe \
        --enable-ilbc \
        --enable-ilbc-webrtc \
        --enable-isac-float \
@@ -110,9 +98,9 @@ CONFIGURE_ARGS+= \
        --with-libpq="$(STAGING_DIR)/usr" \
        --with-mysql="$(STAGING_DIR)/usr" \
        --without-wphwec \
-       --with-libgsm="$(STAGING_DIR)/usr/include/gsm" \
+       --without-libgsm \
        --with-libspeex="$(STAGING_DIR)/usr/include" \
-       --with-amrnb="$(STAGING_DIR)/usr" \
+       --without-amrnb \
        --with-spandsp="$(STAGING_DIR)/usr/include" \
        --without-pwlib \
        --without-openh323 \
@@ -144,29 +132,11 @@ define Package/$(PKG_NAME)/install
        $(INSTALL_BIN) ./files/yate.init $(1)/etc/init.d/yate
 endef
 
-define Package/$(PKG_NAME)-scripts-php/install
-       $(INSTALL_DIR) $(1)/usr/share/yate/scripts
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/leavemail.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/queue_in.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/queue_out.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/route.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/voicemail.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/libvoicemail.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/libyatechan.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/libyateivr.php $(1)/usr/share/yate/scripts/
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/libyate.php $(1)/usr/share/yate/scripts/
-endef
-
 define Package/$(PKG_NAME)-scripts-perl/install
        $(INSTALL_DIR) $(1)/usr/share/yate/scripts
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/Yate.pm $(1)/usr/share/yate/scripts/
 endef
 
-define Package/$(PKG_NAME)-scripts-python/install
-       $(INSTALL_DIR) $(1)/usr/share/yate/scripts
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/yate/scripts/libyate.py $(1)/usr/share/yate/scripts/
-endef
-
 define Package/$(PKG_NAME)-sounds/install
        $(INSTALL_DIR) $(1)/usr/share/yate/sounds
        $(CP) $(PKG_INSTALL_DIR)/usr/share/yate/sounds/ $(1)/usr/share/yate/
@@ -217,9 +187,7 @@ endef
 
 $(eval $(call BuildPackage,$(PKG_NAME)))
 $(eval $(call BuildPackage,$(PKG_NAME)-collection-basic))
-$(eval $(call BuildPackage,$(PKG_NAME)-scripts-php))
 $(eval $(call BuildPackage,$(PKG_NAME)-scripts-perl))
-$(eval $(call BuildPackage,$(PKG_NAME)-scripts-python))
 $(eval $(call BuildPackage,$(PKG_NAME)-sounds))
 $(eval $(call BuildPlugin,accfile,server,SIP or H.323 client (from file),))
 $(eval $(call BuildPlugin,alsachan,client,ALSA Sound Channel,+alsa-lib))
@@ -247,7 +215,6 @@ $(eval $(call BuildPlugin,eventlogs,server,Write events and alarms to log files,
 $(eval $(call BuildPlugin,extmodule,,External Module Handler,))
 $(eval $(call BuildPlugin,faxchan,,Spandsp Fax Channel,+libspandsp))
 $(eval $(call BuildPlugin,filetransfer,,File Transfer Driver,))
-$(eval $(call BuildPlugin,gsmcodec,,GSM Codec,+libgsm))
 $(eval $(call BuildPlugin,gvoice,,Google Voice support,))
 $(eval $(call BuildPlugin,h323chan,,Open H.323 Channel,+libopenh323 @BROKEN)) # libopenh323 doesn't create package or stagin_dir includes or libs
 $(eval $(call BuildPlugin,heartbeat,server,Linux-HA compatible heartbeat,))
@@ -257,10 +224,10 @@ $(eval $(call BuildPlugin,isaccodec,,internet Speech Audio Codec,))
 $(eval $(call BuildPlugin,isupmangler,sig,ISUP parameter mangling in a STP,))
 $(eval $(call BuildPlugin,jabberclient,client,Jabber Client,))
 $(eval $(call BuildPlugin,jabberserver,jabber,Jabber Server,))
-$(eval $(call BuildPlugin,jbfeatures,jabber,Jabber Server Features,))
 $(eval $(call BuildPlugin,javascript,,Routing using the embedded Javascript language,))
+$(eval $(call BuildPlugin,jbfeatures,jabber,Jabber Server Features,))
 $(eval $(call BuildPlugin,lateroute,server,Last Chance Routing,))
-$(eval $(call BuildPlugin,lksctp,server,SCTP sockets using linux kernel,@BROKEN)) # Missing libraries/header files
+$(eval $(call BuildPlugin,lksctp,server,SCTP sockets using linux kernel,@BROKEN))
 $(eval $(call BuildPlugin,mgcpca,server,Media Gateway Control Protocol Agent,))
 $(eval $(call BuildPlugin,mgcpgw,server,Media Gateway Control Protocol Gateway,))
 $(eval $(call BuildPlugin,moh,,On Hold (music) Generator,))
@@ -268,7 +235,7 @@ $(eval $(call BuildPlugin,monitoring,server,Monitoring/gathering Information,))
 $(eval $(call BuildPlugin,mrcpspeech,server,MRCP v2 Voice/Tone Detector and Synthesizer,))
 $(eval $(call BuildPlugin,msgsniff,,Sample Message Sniffer,))
 $(eval $(call BuildPlugin,mux,,Data Multiplexor,))
-$(eval $(call BuildPlugin,mysqldb,server,MySQL Backend DB,+libmysqlclient-r))
+$(eval $(call BuildPlugin,mysqldb,server,MySQL Backend DB,+libmysqlclient-r @BROKEN))
 $(eval $(call BuildPlugin,openssl,,Encrypted transport (OpenSSL),+libopenssl))
 $(eval $(call BuildPlugin,osschan,client,OSS Sound Channel,))
 $(eval $(call BuildPlugin,park,server,Call Parking,))
@@ -276,14 +243,14 @@ $(eval $(call BuildPlugin,pbx,,PBX Message Handlers,))
 $(eval $(call BuildPlugin,pbxassist,server,Full featured PBX and IVR,))
 $(eval $(call BuildPlugin,pgsqldb,server,PostgrestSQL Backend DB,+libpq))
 $(eval $(call BuildPlugin,presence,server,Presence,))
-$(eval $(call BuildPlugin,regfile,server,Registration based on users in file,))
-$(eval $(call BuildPlugin,register,server,Call Detail Record to a database,))
 $(eval $(call BuildPlugin,queues,server,Call Distribution and Queues from Database,))
 $(eval $(call BuildPlugin,queuesnotify,server,Notify when queued call status changes,))
 $(eval $(call BuildPlugin,regexroute,,Regular Expression Based Routing,))
+$(eval $(call BuildPlugin,regfile,server,Registration based on users in file,))
+$(eval $(call BuildPlugin,register,server,Call Detail Record to a database,))
 $(eval $(call BuildPlugin,rmanager,,Yate Remote Management,))
-$(eval $(call BuildPlugin,sip_cnam_lnp,sip,Query CNAM and LNP databases using SIP INVITE,))
 $(eval $(call BuildPlugin,sigtransport,server,SIGTRAN (SS7 over IP) connection provider,))
+$(eval $(call BuildPlugin,sip_cnam_lnp,sip,Query CNAM and LNP databases using SIP INVITE,))
 $(eval $(call BuildPlugin,sipfeatures,server,SIP Features (SUBSCRIBE/NOTIFY),))
 $(eval $(call BuildPlugin,speexcodec,,Speex Codec,+libspeex))
 $(eval $(call BuildPlugin,subscription,server,Subcription handler and presence notifier,))
@@ -295,11 +262,12 @@ $(eval $(call BuildPlugin,wavefile,,Wav file Record and Playback,))
 $(eval $(call BuildPlugin,wpcard,server,Wanpipe PRI cards Signalling and Data Driver,@BROKEN)) # Mising wanpipe and PRI libraries
 $(eval $(call BuildPlugin,yiaxchan,,IAX Channel,))
 $(eval $(call BuildPlugin,yjinglechan,,Jingle Channel,))
-$(eval $(call BuildPlugin,yrtpchan,,RTP Channel and Other Data Helper,))
 $(eval $(call BuildPlugin,yradius,server,RADIUS Client,))
+$(eval $(call BuildPlugin,yrtpchan,,RTP Channel and Other Data Helper,))
 $(eval $(call BuildPlugin,ysigchan,server,SS7/ISDN Protocols - Yate Signalling Library,))
 $(eval $(call BuildPlugin,ysipchan,,SIP Channel,))
-$(eval $(call BuildPlugin,ysockschan,,SOCKS Channel,))
 $(eval $(call BuildPlugin,ysnmpagent,server,SNMP Protocol Agent,,/usr/share/yate/data/NULL-TEAM-MIB.txt /usr/share/yate/data/snmp_mib.conf /usr/share/yate/data/YATE-MIB.txt))
+$(eval $(call BuildPlugin,ysockschan,,SOCKS Channel,))
 $(eval $(call BuildPlugin,ystunchan,,STUN Support,))
 $(eval $(call BuildPlugin,zlibcompress,,Zlib Compression,+zlib))
+