perl: Install /usr/bin/prove so test harness works
[packages.git] / lang / perl / perlbase.mk
index d1cad97..595cb1b 100644 (file)
@@ -1466,7 +1466,9 @@ TITLE:=Test perl module
 endef
 
 define Package/perlbase-test/install
-$(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/prove $(1)/usr/bin/
+       $(call perlmod/Install,$(1),Test Test.pm,Test/Harness/TAP.pod Test/Tutorial.pod)
 endef
 
 $(eval $(call BuildPackage,perlbase-test))