dynamically enable/disable kernel config options for kmod packages based on build...
[openwrt.git] / include / verbose.mk
index 525fbf1..6b2d6d0 100644 (file)
@@ -18,20 +18,29 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
+ifeq ($(IS_TTY),1)
+  _Y:="\\033[33m" # yellow
+  _N:="\\033[m" #normal
+endif
+
+define MESSAGE
+       echo -e "$(_Y)$(1)$(_N)" >&3
+endef
+
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
     trace: FORCE
        @[ -f "$(MAKECMDGOALS)" ] || { \
                [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+               $(call MESSAGE, "make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)"); \
        }
   else
     export QUIET:=1
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif
-    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; /bin/false; } } 3>&1 4>&2; cmd
+    MAKE:=cmd() { $(MAKE) $$* || {  echo "Build failed. Please re-run make with V=99 to see what's going on"; false; } } 3>&1 4>&2; cmd
   endif
 
   .SILENT: $(MAKECMDGOALS)