madwifi: remove wds type of wifi-iface without essid, imho it never worked properly...
[openwrt.git] / include / toplevel.mk
index e13d667..906a9a1 100644 (file)
@@ -44,8 +44,8 @@ prepare-tmpinfo: FORCE
        ./scripts/metadata.pl package_mk tmp/.packageinfo > tmp/.packagedeps || { rm -f tmp/.packagedeps; false; }
        touch $(TOPDIR)/tmp/.build
 
-.config: ./scripts/config/conf prepare-tmpinfo
-       @+if [ -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
+.config: ./scripts/config/conf prepare-tmpinfo $(if $(CONFIG_HAVE_DOT_CONFIG),,FORCE)
+       @+if [ \! -f .config ] || ! grep CONFIG_HAVE_DOT_CONFIG .config >/dev/null; then \
                [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig $(PREP_MK); \
        fi