base-files: properly escape strings for version info
[openwrt.git] / include / toplevel.mk
index 23d70ac..2e89c0b 100644 (file)
@@ -6,7 +6,7 @@
 # See /LICENSE for more information.
 #
 
-RELEASE:=Barrier Breaker
+RELEASE:=Chaos Calmer
 PREP_MK= OPENWRT_BUILD= QUIET=0
 
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
@@ -156,6 +156,15 @@ prereq:: prepare-tmpinfo .config
        @+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
        @+$(NO_TRACE_MAKE) -r -s $@
 
+ifeq ($(SDK),1)
+
+%::
+       @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+       @./scripts/config/conf --defconfig=.config Config.in
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+
+else
+
 %::
        @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
        @( \
@@ -167,6 +176,8 @@ prereq:: prepare-tmpinfo .config
        )
        @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
 
+endif
+
 help:
        cat README