mac80211: fix sending probe requests in client mode, fixes connecting to hidden netwo...
[openwrt.git] / include / toplevel.mk
index f44dc81..0918298 100644 (file)
@@ -51,6 +51,8 @@ export SCAN_COOKIE
 
 SUBMAKE:=umask 022; $(SUBMAKE)
 
+ULIMIT_FIX=_limit=`ulimit -n`; [ "$$_limit" = "unlimited" -o "$$_limit" -ge 1024 ] || ulimit -n 1024;
+
 prepare-mk: FORCE ;
 
 prepare-tmpinfo: FORCE
@@ -146,10 +148,10 @@ prereq:: prepare-tmpinfo .config
                cp .config tmp/.config; \
                ./scripts/config/conf -D tmp/.config -w tmp/.config Config.in > /dev/null 2>&1; \
                if ./scripts/kconfig.pl '>' .config tmp/.config | grep -q CONFIG; then \
-                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
+                       echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!" >&2; \
                fi \
        )
-       @+$(SUBMAKE) -r $@
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
 
 help:
        cat README