speed up metadata scanning a lot by avoiding unnecessary shell commands and make...
[openwrt.git] / include / quilt.mk
index 358b64b..c5245a8 100644 (file)
@@ -3,9 +3,8 @@
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-#
 
-ifneq ($(__quilt_inc),1)
+ifneq ($(if $(DUMP),1,$(__quilt_inc)),1)
 __quilt_inc:=1
 
 ifeq ($(TARGET_BUILD),1)
@@ -13,6 +12,8 @@ ifeq ($(TARGET_BUILD),1)
 endif
 PATCH_DIR?=./patches
 FILES_DIR?=./files
+HOST_PATCH_DIR?=$(PATCH_DIR)
+HOST_FILES_DIR?=$(FILES_DIR)
 
 ifeq ($(MAKECMDGOALS),refresh)
   override QUILT=1
@@ -78,12 +79,14 @@ endif
 
 define Host/Patch/Default
        $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
-       $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+       $(call PatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
@@ -122,7 +125,7 @@ define Quilt/Refresh/Kernel
        $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
 endef
 
-define Build/Quilt
+define Quilt/Template
   $($(2)STAMP_PATCHED): $($(2)STAMP_PREPARED)
        @( \
                cd $(1)/patches; \