[kernel] disable crashlog on ARM platforms for the moment
[openwrt.git] / include / prereq-build.mk
index afb92ff..228fcdc 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,16 +18,9 @@ $(eval $(call Require,non-root, \
        Please do not compile as root. \
 ))
 
-define Require/umask-0022
-       [ "$$(shell umask)" -eq 22 ]
-endef
-$(eval $(call Require,umask-0022, \
-       Please compile with umask 0022. \
-))
-
 # Required for the toolchain
 define Require/working-make
-       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
+       $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 == "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null
 endef
 
 $(eval $(call Require,working-make, \
@@ -100,10 +93,6 @@ $(eval $(call RequireCommand,gawk, \
        Please install GNU awk. \
 ))
 
-$(eval $(call RequireCommand,flex, \
-       Please install flex. \
-))
-
 $(eval $(call RequireCommand,unzip, \
        Please install unzip. \
 ))
@@ -128,6 +117,14 @@ $(eval $(call RequireCommand,wget, \
        Please install wget. \
 ))
 
+define Require/git
+       git --version | awk '($$$$1 == "git") && ($$$$2 == "version") && ($$$$3 >= "1.6.5") { print "ok" }' | grep ok > /dev/null
+endef
+
+$(eval $(call Require,git, \
+       Please install git (git-core) v1.6.5 or later. \
+))
+
 define Require/gnutar
        $(TAR) --version 2>&1 | grep GNU > /dev/null
 endef