mkfwimage: Increase RSPRO maximum size to 0xF00000 (15 MiB)
[openwrt.git] / include / image.mk
index 8f895a3..c7da060 100644 (file)
@@ -87,6 +87,13 @@ define Image/BuildKernel/MkuImageARM
                -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(2) $(3)
 endef
 
+define Image/BuildKernel/MkFIT
+       $(TOPDIR)/scripts/mkits.sh \
+               -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) -d $(3) -C $(4) -a $(5) -e $(6) \
+               -A $(ARCH) -v $(LINUX_VERSION)
+       PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
+endef
+
 define Image/mkfs/jffs2/sub
                # FIXME: removing this line will cause strange behaviour in the foreach loop below
                $(STAGING_DIR_HOST)/bin/mkfs.jffs2 $(3) --pad -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(2) -d $(TARGET_DIR) -v 2>&1 1>/dev/null | awk '/^.+$$$$/'
@@ -132,6 +139,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
                        --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+                       --squash-uids \
                        -o $(KDIR)/root.ubifs \
                        -d $(TARGET_DIR)
         endif