[kernel] remove 2.6.24, no target is relying on it
[openwrt.git] / include / host-build.mk
index 3d1983b..af46c3e 100644 (file)
@@ -78,6 +78,15 @@ define Host/Compile
   $(call Host/Compile/Default)
 endef
 
+define Host/Install/Default
+       $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Install
+  $(call Host/Install/Default)
+endef
+
+
 ifneq ($(if $(HOST_QUILT),,$(CONFIG_AUTOREBUILD)),)
   define HostHost/Autoclean
     $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
@@ -94,6 +103,14 @@ define Download/default
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
+define Host/Exports/Default
+  $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*),-I $$(p))
+  $(1) : export STAGING_PREFIX=$$(STAGING_DIR_HOST)
+  $(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig
+  $(1) : export PKG_CONFIG_LIBDIR=$$(STAGING_DIR_HOST)/lib/pkgconfig
+endef
+Host/Exports=$(Host/Exports/Default)
+
 ifndef DUMP
   define HostBuild
   $(if $(HOST_QUILT),$(Host/Quilt))
@@ -106,10 +123,12 @@ ifndef DUMP
        $(call Host/Prepare)
        touch $$@
 
+  $(call Host/Exports,$(STAMP_CONFIGURED))
   $(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
        $(call Host/Configure)
        touch $$@
 
+  $(call Host/Exports,$(STAMP_BUILT))
   $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
        $(call Host/Compile)
        touch $$@
@@ -128,6 +147,7 @@ ifndef DUMP
     compile: host-compile
     install: host-install
     clean: host-clean
+    update: host-update
   else
     host-compile: $(HOST_STAMP_INSTALLED)
   endif