[package] owipcalc: fix output formatting quirks
[openwrt.git] / include / host-build.mk
index dbd1c3a..6fc29b3 100644 (file)
@@ -45,6 +45,7 @@ define Host/Prepare
 endef
 
 HOST_CONFIGURE_VARS = \
+       CC="$(HOSTCC)" \
        CFLAGS="$(HOST_CFLAGS)" \
        CPPFLAGS="$(HOST_CFLAGS)" \
        LDFLAGS="$(HOST_LDFLAGS)" \
@@ -112,6 +113,7 @@ define Download/default
   SUBDIR:=$(PKG_SOURCE_SUBDIR)
   VERSION:=$(PKG_SOURCE_VERSION)
   MD5SUM:=$(PKG_MD5SUM)
+  MIRROR_MD5SUM:=$(PKG_MIRROR_MD5SUM)
 endef
 
 define Host/Exports/Default
@@ -154,6 +156,7 @@ ifndef DUMP
     install: host-install
     clean: host-clean
     update: host-update
+    refresh: host-refresh
 
     $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
                $(foreach hook,$(Hooks/HostCompile/Pre),$(call $(hook))$(sep))