Restore the gpio.h file, platform.c uses the generic GPIO API
[openwrt.git] / docs / Makefile
index 9e888a4..82381e3 100644 (file)
@@ -6,16 +6,16 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
 all:
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
-       $(MAKE) openwrt.pdf openwrt.html
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
 
-.prereq:
-       $(MAKE) prereq
+$(TMP_DIR)/.prereq-docs:
+       $(NO_TRACE_MAKE) prereq
        touch $@
 
 openwrt.html: $(DEPS)