allow more complex defaults in menuconfig
[openwrt.git] / Makefile
index ec1e367..f93b008 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -38,21 +38,21 @@ endif
 endif
 export OPENWRTVERSION
 
-.pkginfo:
+all:
+
+.pkginfo: FORCE
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) DUMP=1 -f $$makefile 2>&- || true; \
+       @-for dir in package/*/; do \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
-       
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
-.pkginfo: pkginfo-clean
 endif
 
 .config.in: .pkginfo
        ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
-pkginfo-clean:
+pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
 scripts/config/mconf: .config.in
@@ -70,6 +70,14 @@ config: scripts/config/conf
 config-clean:
        $(MAKE) -C scripts/config clean
 
-.PHONY: pkginfo-clean
+package/%: .pkginfo
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%: .pkginfo
+       $(MAKE) -C target $(patsubst target/%,%,$@)
 
+toolchain/%:
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
+.PHONY: FORCE
+FORCE: