allow more complex defaults in menuconfig
[openwrt.git] / Makefile
index d82d618..f93b008 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -38,20 +38,21 @@ endif
 endif
 export OPENWRTVERSION
 
-ifeq ($(shell ./scripts/timestamp.pl -p .pkginfo package),package)
-.pkginfo: pkginfo-clean
-endif
+all:
 
-.pkginfo:
+.pkginfo: FORCE
+ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
-       @-for makefile in package/*/Makefile; do \
-               echo Source-Makefile: $$makefile; \
-               $(MAKE) DUMP=1 -f $$makefile 2>&- || true; \
+       @-for dir in package/*/; do \
+               echo Source-Makefile: $${dir}Makefile; \
+               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
-       
+endif
+
 .config.in: .pkginfo
+       ./scripts/gen_menuconfig.pl < $< > $@ || rm -f $@
 
-pkginfo-clean:
+pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
 scripts/config/mconf: .config.in
@@ -63,12 +64,20 @@ scripts/config/conf: .config.in
 menuconfig: scripts/config/mconf
        $< Config.in
 
-config: scripts/config/mconf
+config: scripts/config/conf
        $< Config.in
 
 config-clean:
        $(MAKE) -C scripts/config clean
 
-.PHONY: pkginfo-clean
+package/%: .pkginfo
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%: .pkginfo
+       $(MAKE) -C target $(patsubst target/%,%,$@)
 
+toolchain/%:
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
+.PHONY: FORCE
+FORCE: