add openssl
[openwrt.git] / Makefile
index 8a2e6bb..92a49bf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -38,7 +38,7 @@ endif
 endif
 export OPENWRTVERSION
 
-all:
+all: world
 
 .pkginfo: FORCE
 ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
@@ -55,29 +55,54 @@ endif
 pkginfo-clean: FORCE
        -rm -f .pkginfo .config.in
 
-scripts/config/mconf: .config.in
+./scripts/config/mconf: .config.in
        $(MAKE) -C scripts/config all
 
-scripts/config/conf: .config.in
+./scripts/config/conf: .config.in
        $(MAKE) -C scripts/config conf
 
-menuconfig: scripts/config/mconf
+config: ./scripts/config/conf FORCE
        $< Config.in
 
-config: scripts/config/conf
+defconfig: ./scripts/config/conf FORCE
+       touch .config
+       $< -D .config Config.in
+
+oldconfig: ./scripts/config/conf FORCE
+       $< -o Config.in
+
+menuconfig: ./scripts/config/mconf FORCE
        $< Config.in
 
-config-clean:
+config-clean: FORCE
        $(MAKE) -C scripts/config clean
 
-package/%:
+package/%: .pkginfo FORCE
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%:
+target/%: .pkginfo FORCE
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
-toolchain/%:
+toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
+world: ./scripts/config/conf FORCE
+       touch .config
+       $< -D .config Config.in >/dev/null 2>/dev/null
+       $(MAKE) toolchain/install
+       $(MAKE) target/compile
+       $(MAKE) package/compile
+       $(MAKE) package/install
+       $(MAKE) target/install
+
+clean: FORCE
+       rm -rf build_* bin
+
+dirclean: clean
+       rm -rf staging_dir_* toolchain_build_*
+
+distclean: dirclean config-clean
+       rm -rf dl .*config* .pkg*
+
 .PHONY: FORCE
 FORCE: