Make modular and fix linking
[openwrt.git] / Makefile
index cd94233..1b8d968 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -74,7 +74,6 @@ package_install: package_compile toolchain
 #
 #############################################################
 
-
 # In this section, we need .config
 include .config.cmd
 
@@ -108,6 +107,16 @@ $(BUILD_DIR):
 
 source: $(TARGETS_SOURCE)
 
+
+package/%:
+       $(MAKE) -C package $(patsubst package/%,%,$@)
+
+target/%:
+       $(MAKE) -C target $(patsubst target/%,%,$@)
+
+toolchain/%:
+       $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
+
 #############################################################
 #
 # Cleanup and misc junk
@@ -120,6 +129,7 @@ image_clean:
        
 target_clean: image_clean
        rm -rf $(TARGET_DIR)
+       rm -rf $(BUILD_DIR)/linux-*/root
 
 clean: target_clean
        @$(MAKE) -C $(CONFIG) clean