[packages_10.03.2] radsecproxy: merge r29052, r29199, r29503
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:00:18 +0000 (16:00 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:00:18 +0000 (16:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30247 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/radsecproxy/Makefile
net/radsecproxy/files/radsecproxy.init

index e1b0619..67d5e12 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2009 OpenWrt.org
+# Copyright (C) 2008-20211 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radsecproxy
-PKG_VERSION:=1.4.2
+PKG_VERSION:=1.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://software.uninett.no/radsecproxy/
-PKG_MD5SUM:=ccdff609c72c0862235b9119323345a8
+PKG_MD5SUM:=c65742a1b471c572ca7f6d11000d41f5
 
 PKG_INSTALL:=1
 
@@ -35,6 +35,11 @@ endef
 CONFIGURE_ARGS+= \
        --with-ssl="$(STAGING_DIR)/usr"
 
+#TARGET_CFLAGS += -ansi
+#TARGET_CFLAGS += -std=c99
+TARGET_CFLAGS += -Wno-long-long
+
+
 define Package/radsecproxy/install
        $(INSTALL_DIR) $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/radsecproxy $(1)/usr/sbin/
@@ -44,5 +49,9 @@ define Package/radsecproxy/install
        $(INSTALL_BIN) ./files/radsecproxy.init $(1)/etc/init.d/radsecproxy
 endef
 
+define Package/radsecproxy/conffiles
+/etc/radsecproxy.conf
+endef
+
 $(eval $(call BuildPackage,radsecproxy))
 
index 9576d96..b1b4f8e 100644 (file)
@@ -1,16 +1,12 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=50
 
-DEFAULT=/etc/default/radsecproxy
-OPTIONS=""
-
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       /usr/sbin/radsecproxy $OPTIONS
+       service_start /usr/sbin/radsecproxy
 }
 
 stop() {
-       killall radsecproxy
+       service_stop /usr/sbin/radsecproxy
 }