[packages_10.03.2] scmpc: merge r28968, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:40:00 +0000 (16:40 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:40:00 +0000 (16:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30285 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/scmpc/Makefile
sound/scmpc/files/scmpc.init

index de36e41..a067f82 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scmpc
 PKG_VERSION:=0.2.2
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.berlios.de/scmpc
@@ -49,7 +49,11 @@ define Package/scmpc/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/scmpc.init $(1)/etc/init.d/scmpc
        $(INSTALL_DIR) $(1)/etc
-       $(CP) $(PKG_BUILD_DIR)/examples/scmpc.conf $(1)/etc
+       $(CP) $(PKG_BUILD_DIR)/examples/scmpc.conf $(1)/etc/
+endef
+
+define Package/scmpc/conffiles
+/etc/scmpc.conf
 endef
 
 $(eval $(call BuildPackage,scmpc))
index 5b12d35..5327b6b 100644 (file)
@@ -1,12 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=94
 
+SERVICE_USE_PID=1
+
 start() {
-       mkdir -p /var/lib/scmpc
-       /usr/bin/scmpc
+       mkdir -m 0755 -p /var/lib/scmpc
+       service_start /usr/bin/scmpc
 }
 
 stop() {
-       killall scmpc
+       service_stop /usr/bin/scmpc
 }