[packages_10.03.2] pcsc-lite: merge r28944
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:51:55 +0000 (16:51 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:51:55 +0000 (16:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30298 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/pcsc-lite/Makefile
utils/pcsc-lite/files/pcscd.init

index f8c434c..ad0b9b5 100644 (file)
@@ -1,8 +1,15 @@
+#
+# Copyright (C) 2009-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcsc-lite
 PKG_VERSION:=1.5.5
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://alioth.debian.org/frs/download.php/3082
index cd9ea27..9a7a905 100644 (file)
@@ -1,11 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
+
 START=50
 
+SERVICE_PID_FILE=/var/run/pcscd/pcscd.pid
+
 start() {
-       pcscd
+       service_start /usr/sbin/pcscd
 }
 
 stop() {
-       killall pcscd
+       service_stop /usr/sbin/pcscd
 }