[packages_10.03.2] psmisc: skip fuser mount into initialization due to missing posix_...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Feb 2012 12:46:18 +0000 (12:46 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Feb 2012 12:46:18 +0000 (12:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30331 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/psmisc/Makefile
utils/psmisc/patches/100-no-mountinfo.patch [new file with mode: 0644]

index 2a54b5e..9009466 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=psmisc
 PKG_VERSION:=22.14
-PKG_RELEASE:=2
+PKG_RELEASE:=2.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/psmisc
diff --git a/utils/psmisc/patches/100-no-mountinfo.patch b/utils/psmisc/patches/100-no-mountinfo.patch
new file mode 100644 (file)
index 0000000..14790d9
--- /dev/null
@@ -0,0 +1,20 @@
+Index: psmisc-22.14/src/fuser.c
+===================================================================
+--- psmisc-22.14.orig/src/fuser.c
++++ psmisc-22.14/src/fuser.c
+@@ -1852,6 +1852,7 @@ clear_mntinfo(void)
+ static void
+ init_mntinfo(void)
+ {
++#if 0
+       char mpoint[PATH_MAX+1];
+       int mid, parid, max = 0;
+       uint maj, min;
+@@ -1904,6 +1905,7 @@ init_mntinfo(void)
+               errno = EBADE;
+       }
+       join(&sort, &mntinfo);
++#endif
+ }
+ /*