[packages_10.03.2] xinetd: merge r28748, r28908
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:35:24 +0000 (16:35 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:35:24 +0000 (16:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30281 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xinetd/Makefile
net/xinetd/files/xinetd.init

index 9c33cdd..52b1dea 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
 PKG_VERSION:=2.3.14
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xinetd.org/
index a1747f0..1437f58 100644 (file)
@@ -1,18 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-DEFAULT=/etc/default/xinetd
-RUN_D=/var/run
-PID_F=$RUN_D/xinetd.pid
+SERVICE_USE_PID=1
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       xinetd $OPTIONS
+       service_start /usr/sbin/xinetd -pidfile /var/run/xinetd.pid
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/xinetd
 }