[packages_10.03.2] tftp-hpa: merge r29074
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:16:01 +0000 (16:16 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 16:16:01 +0000 (16:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30267 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tftp-hpa/Makefile
net/tftp-hpa/files/tftpd-hpa.init

index 5b44603..45f246f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tftp-hpa
 PKG_VERSION:=0.48
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/software/network/tftp
index 1b361d9..c3432ed 100644 (file)
@@ -1,14 +1,13 @@
 #!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=50
 
-RUN_D=/var/tftpd-hpa
-
 start() {
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       tftpd-hpa -l -s $RUN_D
+       mkdir -m 0755 -p /var/tftpd-hpa
+       service_start /usr/sbin/tftpd-hpa -l -s /var/tftpd-hpa
 }
 
 stop() {
-       killall tftpd-hpa
+       service_stop /usr/sbin/tftpd-hpa
 }