[packages_10.03.2] libnatpmp: merge r27692, r29757
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:37:05 +0000 (18:37 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 4 Feb 2012 18:37:05 +0000 (18:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30053 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libnatpmp/Makefile
libs/libnatpmp/patches/001-cross_compile.patch

index df2ab55..40d7b75 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnatpmp
-PKG_VERSION:=20110618
+PKG_VERSION:=20110808
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
-PKG_MD5SUM:=6a5fdc8aa6c8602ea96567dabe51d6d3
+PKG_MD5SUM:=22a1225b890471a7750a9bf26eb863f7
 
 PKG_INSTALL:=1
 
@@ -59,7 +59,8 @@ endef
 
 MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
-       PREFIX="$(PKG_INSTALL_DIR)"
+       PREFIX="$(PKG_INSTALL_DIR)" \
+       OS="Linux"
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
index 0869f2d..1136f93 100644 (file)
@@ -1,17 +1,9 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -4,14 +4,15 @@
- # (c) 2007-2011 Thomas Bernard
- # http://miniupnp.free.fr/libnatpmp.html
--OS = $(shell uname -s)
-+OS = Linux
- CC = gcc
- INSTALL = install
+@@ -11,7 +11,8 @@ INSTALL = install
  # APIVERSION is used in soname
  APIVERSION = 1
- LDFLAGS = -Wl,--no-undefined
#LDFLAGS = -Wl,--no-undefined
 -CFLAGS = -O -fPIC -Wall -DENABLE_STRNATPMPERR
 +COPTS = -O
 +CFLAGS = $(COPTS) -fPIC -Wall -DENABLE_STRNATPMPERR