rpcd: move menu.d to /usr/share/rpcd
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Sep 2013 11:51:35 +0000 (13:51 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Sep 2013 11:51:35 +0000 (13:51 +0200)
luci2/Makefile
luci2/src/rpcd/luci2.c

index 88cf3e0..e83cf51 100644 (file)
@@ -37,8 +37,8 @@ endef
 define Package/luci2/install
        $(INSTALL_DIR) $(1)/www
        $(CP) ./htdocs/* $(1)/www/
-       $(INSTALL_DIR) $(1)/usr/share/luci2
-       $(CP) ./share/* $(1)/usr/share/luci2/
+       $(INSTALL_DIR) $(1)/usr/share/rpcd
+       $(CP) ./share/* $(1)/usr/share/rpcd/
        $(INSTALL_DIR) $(1)/usr/lib/rpcd
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/rpcd/luci2.so $(1)/usr/lib/rpcd/
        $(INSTALL_DIR) $(1)/usr/libexec $(1)/www/cgi-bin
index 2b1a750..23bd629 100644 (file)
@@ -41,7 +41,7 @@
 #define RPC_LUCI2_DEF_LOGSIZE       (16 * 1024)
 
 /* location of menu definitions */
-#define RPC_LUCI2_MENU_FILES        "/usr/share/luci2/menu.d/*.json" /* */
+#define RPC_LUCI2_MENU_FILES        "/usr/share/rpcd/menu.d/*.json" /* */
 
 
 static const struct rpc_daemon_ops *ops;