patch: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jun 2014 10:13:25 +0000 (10:13 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jun 2014 10:13:25 +0000 (10:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41200 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/patch/Makefile [deleted file]
devel/patch/patches/100-install.patch [deleted file]

diff --git a/devel/patch/Makefile b/devel/patch/Makefile
deleted file mode 100644 (file)
index 1300855..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2008-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=patch
-PKG_VERSION:=2.5.9
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/patch
-PKG_MD5SUM:=dacfb618082f8d3a2194601193cf8716
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/patch
-  SECTION:=devel
-  CATEGORY:=Development
-  TITLE:=patch
-  URL:=http://www.gnu.org/
-endef
-
-define Package/patch/description
-  The Patch package contains a program for modifying or creating files
-  by applying a "patch" file typically created by the diff program.
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               exec_prefix="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/patch/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/bin/patch $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,patch))
diff --git a/devel/patch/patches/100-install.patch b/devel/patch/patches/100-install.patch
deleted file mode 100644 (file)
index 8d34ba6..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -urN patch-2.5.4.orig/Makefile.in patch-2.5.4/Makefile.in
---- patch-2.5.4.orig/Makefile.in       2008-06-11 10:08:08.000000000 +0200
-+++ patch-2.5.4/Makefile.in    2008-06-11 10:08:26.000000000 +0200
-@@ -42,12 +42,12 @@
- VERSION = @VERSION@
- prefix = @prefix@
--exec_prefix = @exec_prefix@
-+exec_prefix += @exec_prefix@
- bindir = $(exec_prefix)/bin
- # Where to put the manual pages.
--mandir = @mandir@
-+mandir = $(exec_prefix)/@mandir@
- man1dir = $(mandir)/man1
- # Extension (including `.') for the manual page filenames.
- man1ext = .1