[PATCH] ahcpd: fix ticket 3550
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Apr 2009 16:06:57 +0000 (16:06 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Apr 2009 16:06:57 +0000 (16:06 +0000)
Signed-off-by: Gabriel Kerneis <kerneis@pps.jussieu.fr>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15266 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/ahcpd/Makefile
ipv6/ahcpd/files/ahcpd.config
ipv6/ahcpd/files/ahcpd.init

index a983d32..870d8ba 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ahcpd
 PKG_VERSION:=0.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
index 4aca869..58db58b 100755 (executable)
@@ -1,5 +1,4 @@
 config ahcpd
        option interfaces "wl0"
-       # Comment out to actually disable, see ticket 3550
        option no_dns false
        option no_ipv4 true
index a885c54..efd80d3 100644 (file)
@@ -7,8 +7,8 @@ pidfile=/var/run/ahcpd.pid
 ahcpd_config() {
        local cfg="$1"
        config_get interfaces "$cfg" interfaces
-       config_get no_ipv4 "$cfg" no_ipv4
-       config_get no_dns "$cfg" no_dns
+       config_get_bool no_ipv4 "$cfg" no_ipv4 0
+       config_get_bool no_dns "$cfg" no_dns 0
 }
 
 start() {
@@ -16,6 +16,12 @@ start() {
        config_foreach ahcpd_config ahcpd
        mkdir -p /var/lib
        [ -r /usr/lib/ahcp/ahcp.dat ] && authority="-a /usr/lib/ahcp/ahcp.dat"
+       if [ "$no_ipv4" -eq 0 ]; then
+               unset no_ipv4
+       fi
+       if [ "$no_dns" -eq 0 ]; then
+               unset no_dns
+       fi
        if [ -e $pidfile ] ; then
                echo "$pidfile exists -- not starting ahcpd." >&2
        else