[curl]: upgrade to 7.33.0, add myself as maintainer
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Oct 2013 09:09:45 +0000 (09:09 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Oct 2013 09:09:45 +0000 (09:09 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@38429 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/curl/Makefile
libs/curl/patches/200-no_docs_tests.patch

index e8d0276..2c8f4ff 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007-2011 OpenWrt.org
+#
+# Copyright (C) 2007-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.29.0
+PKG_VERSION:=7.33.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=fa5f37f38a8042020e292ce7ec5341ce
+PKG_MD5SUM:=57409d6bf0bd97053b8378dbe0cadcef
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -33,6 +33,7 @@ define Package/curl/Default
   SECTION:=net
   CATEGORY:=Network
   URL:=http://curl.haxx.se/
+  MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 endef
 
 define Package/curl
index 6519a09..43fd812 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -41,7 +41,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
+@@ -66,7 +66,7 @@ CLEANFILES = $(VC6LIBDSP) $(VC8LIBPRJ)
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src include
  pkgconfig_DATA = libcurl.pc
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -326,7 +326,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
+@@ -494,7 +494,7 @@ EXTRA_DIST = CHANGES COPYING maketgz Mak
+ CLEANFILES = $(VC6LIBDSP) $(VC8LIBPRJ)
  bin_SCRIPTS = curl-config
  SUBDIRS = lib src include
 -DIST_SUBDIRS = $(SUBDIRS) tests packages docs
 +DIST_SUBDIRS = $(SUBDIRS) packages
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
- all: all-recursive
+ CSOURCES = file.c timeval.c base64.c hostip.c progress.c formdata.c   \