openrrcp: fix compile on platforms with VFP
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 May 2014 04:51:35 +0000 (04:51 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 May 2014 04:51:35 +0000 (04:51 +0000)
buildbot reported error on platforms with VFP (sunxi,imx6,omap):
ld: error: ../bin/rtl83xx uses VFP register arguments, /tmp/....o does not

CFLAGS were created by acustom shellscript that was setting host
includes paths. this was disabled

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40791 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openrrcp/patches/001-Makefile_honor_CFLAGS_for_VFP.patch [new file with mode: 0644]

diff --git a/net/openrrcp/patches/001-Makefile_honor_CFLAGS_for_VFP.patch b/net/openrrcp/patches/001-Makefile_honor_CFLAGS_for_VFP.patch
new file mode 100644 (file)
index 0000000..1799bda
--- /dev/null
@@ -0,0 +1,7 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,4 +1,3 @@
+-CFLAGS=`/bin/sh Makefile-helper.sh`
+ all: rtl8316b rtl8324 rtl8326 rtl83xx_dlink_des1016d rtl83xx_dlink_des1024d_b1 \
+ rtl83xx_dlink_des1024d_c1 rtl83xx_compex_ps2216 rtl83xx_ovislink_fsh2402gt \