[package] update gstreamer to 0.10.25 (#6301)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Dec 2009 16:48:26 +0000 (16:48 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Dec 2009 16:48:26 +0000 (16:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18679 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/gstreamer/Makefile
multimedia/gstreamer/patches/001-no_docs.patch
multimedia/gstreamer/patches/002-no-shave_mode.patch [new file with mode: 0644]

index 9cf8490..3ff300f 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer
-PKG_VERSION:=0.10.21
-PKG_RELEASE:=3
+PKG_VERSION:=0.10.25
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
-PKG_MD5SUM:=7bad90af3fd81a1535363cf85359125c
+PKG_MD5SUM:=88544e034a051baf472983791d233076
 PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
@@ -61,12 +61,12 @@ define Build/InstallDev
 
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
+               $(PKG_INSTALL_DIR)/usr/lib/*.{so*,la} \
                $(1)/usr/lib/
 
        $(INSTALL_DIR) $(1)/usr/lib/gstreamer-0.10/
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.{so*,a,la} \
+               $(PKG_INSTALL_DIR)/usr/lib/gstreamer-0.10/*.{so*,la} \
                $(1)/usr/lib/gstreamer-0.10
 
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
index 34ca955..716e55f 100644 (file)
@@ -1,37 +1,37 @@
-diff -urN gstreamer-0.10.21/Makefile.am gstreamer-0.10.21.new/Makefile.am
---- gstreamer-0.10.21/Makefile.am      2008-01-09 14:48:03.000000000 +0100
-+++ gstreamer-0.10.21.new/Makefile.am  2009-03-10 20:07:11.000000000 +0100
-@@ -12,14 +12,12 @@
+diff -u --recursive gstreamer-0.10.25-vanilla/Makefile.am gstreamer-0.10.25/Makefile.am
+--- gstreamer-0.10.25-vanilla/Makefile.am      2009-11-14 23:04:56.812541974 -0500
++++ gstreamer-0.10.25/Makefile.am      2009-11-14 23:05:22.744511310 -0500
+@@ -13,14 +13,12 @@
  
- SUBDIRS = \
+ SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
 -      docs \
-       pkgconfig po \
+       po \
        common
  
  # These are all the possible subdirs
- DIST_SUBDIRS = \
+ DIST_SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
 -      docs \
-       pkgconfig po \
+       po \
        common
  
-diff -urN gstreamer-0.10.21/Makefile.in gstreamer-0.10.21.new/Makefile.in
---- gstreamer-0.10.21/Makefile.in      2008-10-02 23:54:23.000000000 +0200
-+++ gstreamer-0.10.21.new/Makefile.in  2009-03-10 20:07:27.000000000 +0100
-@@ -359,7 +359,6 @@
+diff -u --recursive gstreamer-0.10.25-vanilla/Makefile.in gstreamer-0.10.25/Makefile.in
+--- gstreamer-0.10.25-vanilla/Makefile.in      2009-11-14 23:04:56.775542524 -0500
++++ gstreamer-0.10.25/Makefile.in      2009-11-14 23:05:28.561389821 -0500
+@@ -397,7 +397,6 @@
  aclocal_DATA = gst-element-check-@GST_MAJORMINOR@.m4
- SUBDIRS = \
+ SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
 -      docs \
-       pkgconfig po \
+       po \
        common
  
-@@ -367,7 +366,6 @@
+@@ -405,7 +404,6 @@
  # These are all the possible subdirs
- DIST_SUBDIRS = \
+ DIST_SUBDIRS = pkgconfig \
        gst libs plugins tools tests \
 -      docs \
-       pkgconfig po \
+       po \
        common
  
diff --git a/multimedia/gstreamer/patches/002-no-shave_mode.patch b/multimedia/gstreamer/patches/002-no-shave_mode.patch
new file mode 100644 (file)
index 0000000..1d1bded
--- /dev/null
@@ -0,0 +1,16 @@
+diff -u --recursive gstreamer-0.10.25-vanilla/common/shave-libtool.in gstreamer-0.10.25/common/shave-libtool.in
+--- gstreamer-0.10.25-vanilla/common/shave-libtool.in  2009-04-15 16:28:36.000000000 -0400
++++ gstreamer-0.10.25/common/shave-libtool.in  2009-11-14 23:08:34.744433657 -0500
+@@ -41,12 +41,9 @@
+ case "$mode" in
+ compile)
+-    # shave will be called and print the actual CC/CXX/LINK line
+-    preserved_args="$preserved_args --shave-mode=$mode"
+     pass_though=1
+     ;;
+ link)
+-    preserved_args="$preserved_args --shave-mode=$mode"
+     Q="  LINK  "
+     ;;
+ *)