e169-stats: rework makefile patch to be more general
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:45 +0000 (00:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:45 +0000 (00:56 +0000)
Allow the makefile patch to pass CFLAGS, CPPFLAGS, and LDFLAGS

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39803 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/e169-stats/Makefile
net/e169-stats/patches/01-make.patch

index cac9d12..b72f182 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e169-stats
 PKG_VERSION:=0.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.mavetju.org/download
@@ -29,6 +29,9 @@ define Package/e169-stats/description
   Huawei E169 statistics, works with other Huawei's devices.
 endef
 
+MAKE_FLAGS += \
+       LDFLAGS="$(TARGET_LDFLAGS) -lncurses"
+
 define Package/e169-stats/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/e169-stats $(1)/usr/bin/
index 28a56c5..e524efb 100644 (file)
@@ -5,7 +5,7 @@
  
  e169-stats: e169-stats.c
 -      gcc -Wall -o e169-stats e169-stats.c -lcurses
-+      $(CC) -Wall -o e169-stats e169-stats.c -lcurses -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib
++      $(CC) $(CFLAGS) -Wall -o e169-stats e169-stats.c $(CPPFLAGS) $(LDFLAGS)
  
  clean:
        -rm e169-stats *.core