mdk3: fix compile on platforms with VFP
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 May 2014 04:51:29 +0000 (04:51 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 May 2014 04:51:29 +0000 (04:51 +0000)
buildbot reported error on platforms with VFP (sunxi,imx6,omap):
mdk3 uses VFP register arguments, /tmp/ccBN2WMD.o does not
mdk3 uses VFP register arguments, osdep/libosdep.a(osdep.o) does not
mdk3 uses VFP register arguments, osdep/libosdep.a(network.o) does not
mdk3 uses VFP register arguments, osdep/libosdep.a(linux.o) does not
mdk3 uses VFP register arguments, osdep/libosdep.a(radiotap-parser.o) does not
mdk3 uses VFP register arguments, osdep/libosdep.a(common.o) does not
with failed to merge target specific data of file ...

CFLAGS were overwritten so append them instead

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40789 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/mdk3/patches/020-Makefile_honour_CFLAGS_for_VFP.patch [new file with mode: 0644]

diff --git a/net/mdk3/patches/020-Makefile_honour_CFLAGS_for_VFP.patch b/net/mdk3/patches/020-Makefile_honour_CFLAGS_for_VFP.patch
new file mode 100644 (file)
index 0000000..9a420c2
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS                = -g -O3 -Wall -Wextra
++CFLAGS                += -g -O3 -Wall -Wextra
+ LINKFLAGS     = -lpthread
+ DESTDIR               =