netio: fix passing our CFLAGS to the Makefile
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:29 +0000 (00:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:29 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39821 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/netio/Makefile
net/netio/patches/001-Makefile.patch

index 4837382..28fb4be 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netio
 PKG_VERSION:=1.31
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)$(subst .,,$(PKG_VERSION)).zip
 PKG_SOURCE_URL:=http://www.ars.de/ars/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/%24FILE/
@@ -30,7 +30,7 @@ define Package/netio
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)"
+       $(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -DUNIX"
 endef
 
 define Package/netio/install
index 517b16a..1e35baf 100644 (file)
@@ -1,11 +1,13 @@
---- a/Makefile         2011-01-17 17:15:11.000000000 +0100
-+++ b/Makefile         2010-10-14 15:03:42.000000000 +0200
-@@ -84,7 +84,7 @@
+--- a/Makefile
++++ b/Makefile
+@@ -84,8 +84,8 @@ solaris:\r
        $(MAKE) all CC="gcc -O -s" O=.o X= \\r
        CFLAGS="-DUNIX" LFLAGS="" LIBS="-lsocket -lpthread -lnsl" OUT=-o\r
  linux:\r
 -      $(MAKE) all CC="gcc -O -s" O=.o X= \\r
+-      CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o\r
 +      $(MAKE) all CC="$(CC) -O -s" O=.o X= \\r
-       CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o\r
++      LFLAGS="" LIBS="-lpthread" OUT=-o\r
  macosx:\r
        $(MAKE) all CC="gcc -O" O=.o X= \\r
+       CFLAGS="-DUNIX -DSOCKLEN_T" LFLAGS="" LIBS="-lpthread" OUT=-o\r