tayga: fix compile on platforms with VFP
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 May 2014 19:30:59 +0000 (19:30 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 May 2014 19:30:59 +0000 (19:30 +0000)
CFLAGS were set explicitly in configure.ac
and then got included in Makefile; remove them

fix compile error found on buildbot with arch sunxi

several compile errors on .o files:
 tayga uses VFP register arguments, nat64.o does not

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40700 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/tayga/Makefile
ipv6/tayga/patches/001-configure_unset_CFLAGS.patch [new file with mode: 0644]

index 5e1a5df..211f84d 100644 (file)
@@ -12,6 +12,7 @@ PKG_MD5SUM:=7a7b24165ce008df772f398d86fa280e
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/tayga-$(PKG_VERSION)
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/ipv6/tayga/patches/001-configure_unset_CFLAGS.patch b/ipv6/tayga/patches/001-configure_unset_CFLAGS.patch
new file mode 100644 (file)
index 0000000..c56b5f2
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -5,8 +5,6 @@ AC_CONFIG_HEADERS(config.h)
+ AC_PROG_CC
+-CFLAGS='-g -Wall'
+-
+ tayga_conf_path=${sysconfdir}/tayga.conf
+ AC_SUBST(tayga_conf_path)